
Menu's

Overview of the menu options that are available through the main menu (on top of the 
main ScanDir window) and the various PopUp menu's that are available through right-click 
on many area's of the screen. 

Click the '+' sign in the Contents window on the left to expand this topic and select a sub-
topic for more information.

File menu

Scan
Start normal scan: clear item list before displaying the new scan results.

Scan to File
Start scan and write scan results directly to a file. Before the scan operation starts, the Save 
Dialog is opened to specify the file to which the scan results should be written. The Item list 
is not used to display the scan results. Writing scan results directly to a file (and thus 
bypassing the Item list) is very fast.

Save
Use save to write the scan results ( item list ) to an ASCII text file. When Save is selected, the 
Save Dialog is displayed.
The default output filename can be changed in Configuration

Printer Setup
Select the default printer, paper and printer properties.

Printer Font
Select the font that should be used for printed output.

Print
Print scan results ( item list ). A printer dialog is displayed before the print process starts.

Exit
Terminate ( exit program ) ScanDir.

Edit menu

Cut
Cut selected text to clipboard.

Copy
Copy selected text to clipboard.
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Paste
Paste text from clipboard into selected field.

View menu

Theme
Hover over Theme to select one of the available themes. The selected theme is applied and 
the setting is saved. To restore the default theme, select 'Windows'.

Show Hints
Toggle Hints. When Selected, balloon hints are displayed when the mouse hovers over a 
field or button.

Show Rename
View / hide the Rename pane at the bottom of the item list. The Rename pane is used to 
rename a single (selected) item from the item list.

Show Preview
View / hide the Preview pane below the directory tree. The preview pane displays the 
content (if supported) of a selected item from the item list. Common text, image, audio and
video files can be pre-viewed.

Show Progress
Toggle Progress display in statusbar. If selected, the name of the directory that is currently 
scanned is displayed during the Scan process.

Refresh
Refresh directory Tree. The directory tree is rebuilt. This can be usefull if another program 
changed the directory structure or if USB devices have been added or removed.

Reset windowsize
Reset the main window and Copy/move dialog window to their original size.

Items menu
The items (drop-down or popup) menu displays all options. Some options are only available
when one or more filenames are selected from the item list. Options that are not available 
are Grayed out.

Go to...
Switch to the directory that contains the selected item (the drive + pathname of the
selected item will become the current directory).

Bookmark directory
Add the directory (drive + pathname) to the bookmark list.

Open
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Open (execute) the selected item.

Open with...
Specify a program that should open (process) the selected file.

(pre)View as text
View the selected file as a text file. Many text files are recognized by their file extension but 
if the file extension is not recognized by ScanDir you can use this option to display the 
content of a file as ASCII text.

Print selected items
Print item list. Depending on the current setting of the Output Configuration a report or list 
is printed to the default printer (no print dialog). To print using a print dialog, select Print
from the File menu.

Find
Find text in Item list. All items that contain the specified text string are selected
(highlighted).

Select All
Select all items.

Select None
Select no items (de-select all selected items).

Invert selection
Invert selection: de-select all selected items and select all non-selected items.

Sort
Sort item list. By default, the item list is sorted. The default Configuration may have been 
changed however ( using Configuration | Output and selecting [v] NOT sorted ). Use Sort to 
sort unsorted items (this may take some time for a large item list). 

move entry Up
By default, the item list is sorted but individual filenames can be moved Up or Down in the 
list. Use Shitf+U as a shortcut to move an entry Up one position.

move entry Down
By default, the item list is sorted but individual filenames can be moved Up or Down in the
list. Use Shiftt+D as a shortcut to move an entry Down one position.

Clear
Clear the item list.

Copy
Displays the Copy Dialog to copy selected file(s) to another directory. If the target directory 
does not exist, ScanDir will prompt to create it. During the copy operation, files can be 
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renamed (for advanced Rename functions see:below). When files with the same name
already exist in the target directory, copied files are renamed to: "Copy of filename.ext". If 
Options * Confirm Rename is checked, a confirmation message is displayed before the 
copy (rename) takes place.

Move
Displays the Move Dialog to move selected file(s) to another directory. If the target 
directory does not exist, ScanDir will prompt to create it. During the move operation, files 
can be renamed (for advanced Rename functions see:Options * Confirm Rename is checked, 
a confirmation message is displayed before the move (rename) takes place.

Rename
Rename selected file(s). If Options * Confirm Rename is checked, a confirmation message 
is displayed before the rename takes place. If multiple files are selected, the Batch Rename 
Dialog is displayed.

Attrib
Set (or change) file attribute(s). Select this option to invoke the Attribute(s) Dialog. With the 
Attrib dialog the following attributes can be modified: Read-Only, Hidden, System and 
Archive. In addition, the Attribute(s) Dialog can be used to change the Date modified 
and/or Date created for one or more files.

Empty
Empty file. Use the Empty command to empty the selected file(s). When a file is emptied, it's 
content is deleted but the file itself is not deleted, it remains as an empty file.

Split / Join
Displays a Dialog to split or join selected files. Multiple files can be joined (copied one after 
another) into one large file or one large file can be split into several smaller files.

Delete
Delete selected file(s). If Options * Confirm Delete is checked, a confirmation message is
displayed before the delete takes place. Deleted files are kept in the recycle bin (except 
when this function is disabled in Windows).

Purge
Permanently delete selected file(s). Deleted files are NOT kept in the recycle bin! If Options 
* Confirm Purge is checked, a confirmation message is displayed before the purge takes 
place. 

CRC32
Calculate CRC32 checksum for selected files. The calculated checksums are displayed in a 
new window, from which they can be saved to a text file. 

MD5
Calculate MD5 checksum for selected files. The calculated checksums are displayed in a new 
window, from which they can be saved to a text file. 
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Play
Play the selected item(s). The selected items must be audio or video files in a format that is
supported by the default media player

Remove from item list
The selected filename(s) are removed from the item list, but NOT deleted. This option can 
be used if you want to exclude some files from further processing (e.g. rename, save, copy, 
move, split, join, print, save...) on the files in the item list. Files that are removed from the 
item list are also excluded from the statistics that are shown in the information window.

Add files to File list
The selected files are added to the File list. The File list is a list of filenames that are
frequently used (similar to the bookmark function for folders). The File list can be displayed 
by clicking the [File] tab.

Filename to clipboard
Copy the filename (without the pathname) of the selected item to the clipboard.

Path to clipboard
Copy filename, including full path of the selected item to the clipboard.

File info...
Display total number of files and total filesize for the selected items.

Bookmarks menu

Bookmarks allow quick access to preferred directories. Bookmarks are also available in the
Copy / Move dialogs. The bookmark entries are saved in scandir.ini. The number of entries 
to be saved is set with Configuration.

Bookmark current directory
Add the current directory to the bookmark list.

Manage bookmarks
Opens a new window to manually maintain the bookmark list. Entries can be added, 
replaced, deleted, moved up and down the list, or sorted. A browse function is available to 
find directories. Use Clear All to delete all existing bookmark entries.

Bookmarked folders are displayed below the horizontal line. The maximum number of 
Bookmarks is set in Configuration under Interface. This is also the place to specify if
Bookmarks should be saved (or not).

Options menu

Confirm Delete directory
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Ask for confirmation before permanently removing a directory from disk. Changing Confirm 
Delete directory in the Options menu only affects the current ScanDir session. The default 
value for Confirm Delete directory can be set with Configuration.

Confirm Rename directory
Ask for confirmation before renaming directories. Changing Confirm Rename directory in 
the Options menu only affects the current ScanDir session. The default value for Confirm 
Rename directory can be set with Configuration.

Confirm Purge file
Ask for confirmation before permanently removing a file. Changing Confirm Purge file in 
the Options menu only affects the current ScanDir session. The default value for Confirm 
Purge file can be set using Configuration.

Confirm Delete file
Ask for confirmation before permanently removing a file from disk. Changing Confirm 
Delete file in the Options menu only affects the current ScanDir session. The default value 
for Confirm Delete file can be set with Configuration.

Confirm Rename file(s)
Ask for confirmation before renaming files. Confirm Rename works for the Rename function 
and during Copy / Move. Changing Confirm Rename in the Options menu only affects the 
current ScanDir session. The default value for Confirm Rename file(s) can be set with 
Configuration.

Preview Rename file(s)
Display a dialog with old (before) and new (after) filenames, before the rename operation is 
performed. This option has NO effect when when renaming files during Copy / Move. 
Changing Preview Rename in the Options menu only affects the current ScanDir session. 
The default value for Preview Rename file(s) can be saved with Configuration. If the new
filenames are identical to the old filenames (or when no files are found that contain the 'old' 
string) no rename is performed and the dialog window will be empty (0 files will be 
Renamed). 

Confirm Attrib
Ask for confirmation before changing file attributes. Changing Confirm Attrib in the Options 
menu only affects the current ScanDir session. The default value for Confirm Attrib can be 
set with Configuration.

Confirm Empty
Ask for confirmation before one or more file(s) are emptied. Changing Confirm Empty in the 
Options menu only affects the current ScanDir session. The default value for Confirm Empty 
can be set with Configuration.

Log Stopwatch
When selected, the elapsed time of commands is logged.
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Log all commands
When selected, all commands are logged.

Reset selection criteria
Reset selection criteria (re-load from scandir.ini) and clear item list.

Configuration…
Invoke the ScanDir Configuration dialog

Help menu

Help Topics
Display Contents of the Help file.

Online Help
Start browser session for online help pages.

What's new
Display an overview of new, changed or removed functions and a summary of bug fixes.

Jumpstart
Shows in 6 easy steps how to start using ScanDir.

Keyboard
Display Function key assignments and keyboard shortcuts.

License
Display terms for use and distribution.

Information display
Show the Information screen (same as [ i ] button). The information display gives a summary 
of the items in the current Item list, active ScanDir settings and the location of system files. 
Click on a filename to copy it to the clipboard.

About...
Display ScanDir version info. For beta releases build info is displayed.

PopUp menu’s

directory Tree
- Scan: start Scan. See: File menu
- Scan to File: Start scan and write scan results directly to a file. See: File menu
- Refresh: refresh directory list.
- Expand all: Expand all entries under selected folder.
- Collapse all: Collapse all entries under selected folder.
- Create directory: create a new (sub)directory, or a range of directories under the current 
directory.
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- Rename directory: rename the current directory.
- Delete directory: delete the current directory.
- Directory to clipboard: copy the name of the selected directory to the clipboard.
- Bookmark directory: add current directory to bookmarks.
- Add to list: add current directory to the list of directories to scan [List].
- Add to skip list: add current directory to list of directories to skip [Skip].
- Directory info...: display directory information.
- Drive info...: display drive information.

directory List
- Goto: switch to selected directory.
- Clear: empty this directory (include) list;
- Load: load a new directory list from a textfile;
- Save: write this directory list to a textfile;
- Add directory: Open dialog to add a new directory to the directory list.
- Remove directory: Remove selected directory from the directory list.
- Select All: Check all directories in the directory list.
- Select None: Uncheck all directories in the directory list.

Skip directories
- Goto: switch to selected directory.
- Clear: empty this directory (exclude) list;
- Load: load a new directory list from a textfile;
- Save: write this directory list to a textfile;
- Add directory: Open dialog to add a new directory to the directory list.
- Remove directory: Remove selected directory from the directory list.
- Select All: Check all directories in the directory list.
- Select None: Uncheck all directories in the directory list.

Item list
- Goto...: same as Goto... in Items menu
- Bookmark directory: same as Bookmark directory in Items menu
- Open: same as Open in Items menu
- Open with...: same as Open with... in Items menu
- (pre)View as text: same as View as text in Items menu
- Print selected items: same as Print in Items menu
- Find: same as Find in Items menu
- Select All: same as Select All in Items menu
- Select None: same as Select None in Items menu
- Invert: same as Invert in Items menu
- Sort: same as Sort in Items menu
- move entry Up: same as Shift+U in Items menu
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- move entry Down: same as Shift+D Items menu
- Clear: same as Clear in Items menu
- Copy: same as Copy in Items menu
- Move: same as Move in Items menu
- Rename: same as Rename in Items menu
- Attrib: same as Attrib in Items menu
- Empty: same as Empty in Items menu
- Split / Join: same as Split / Join in Items menu
- Delete: same as Delete in Items menu
- Purge: same as Purge in Items menu
- CRC32: same as CRC32 in Items menu
- MD5: same as MD5 in Items menu
- Play: same as Play in Items menu
- Remove from item list: same as Remove from item list in Items menu
- Add files to File list: same as Add files to File list in Items menu
- Filename to clipboard: same as Filename to clipboard in Items menu.
- Path to clipboard: same as Path to clipboard in Items menu.
- File info: same as File info in Items menu

To open a file with the associated program: double click on item in item list.

[Scan] button
The (default) strings below can be configured in the Configuration menu under Custom San
string 1..5 
- select '*.bat *.cpp *.htm* *.ini *.log *.pas *.php* *.txt'
- select '*.jpg *.png *.bmp'
- select '*.mp3 *.wav *.wma'
- select '*.avi *.mpg *.wmv'
- select '*.doc *.xls *.ppt *.acc, *.vsd *.mpp'

Log
- Clear log;
- Print log;
- Save log;
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